EL7 yum repo failed on libprotobuf-c.so.0

EL7 with EPEL repo.

 

Well ligbadu was based on libprotobuf-c version 0, but EL7 choose new version 1.

 

[Fix]:

 

1. install new libprotobuf-c  in force.

 

 

2. download latest libgadu src rpm from koji:

libgadu-1.12.0-4.fc22.src.rpm

 

It’s based on protobuf-c version 1,  and was prepared for fc22, instead of fc21.

 

3. re- compile new rpm for EL7

update libgadu.

 

4. yum update now works .