Install cmake-2.8.12 on EL7

here, Im installing vim plugin YCM and hit cmake version issue.

Step to fix:
1. fetch src.rpm
https://kojipkgs.fedoraproject.org//packages/cmake/2.8.12/3.fc21/src/cmake-2.8.12-3.fc21.src.rpm

2.  build/rebuild

3. install new generated package.

4. also I v put my rpms here:
Link:
http://pan.baidu.com/s/1o6OB8ro

EL7/src.RPMs_IF_YOU_NEED/cmake-2.8.12-3.fc21.src.rpm
/rpm/
cmake-2.8.12-3.el7.centos.x86_64.rpm
cmake-debuginfo-2.8.12-3.el7.centos.x86_64.rpm
cmake-doc-2.8.12-3.el7.centos.x86_64.rpm
cmake-gui-2.8.12-3.el7.centos.x86_64.rpm

pidgin-lwqq new fix!

基本上lwqq的用户都是中文用户,所以这是一篇中文日志。

Linux上的pidgin-lwqq 有一个礼拜没办法登录了。

新的fix在这里:
https://github.com/xiehuc/lwqq/pull/26

很好用。

 

顺便看了一下pidgin的源代码, 吐槽一下某公司员工肯定很打扰社区了。。。

sc001
sc002

update for patch CVE-2015-0235

for details about CVE-2015-0235
Vulnerability Summary for CVE-2015-0235
How To Patch and Protect Linux Server Against the Glibc GHOST Vulnerability # CVE-2015-0235
Qualys Security Advisory CVE-2015-0235
Currently Redhat, CentOS, OracleLinux already have fix on this patch.

Please run.:

To Fix.

After the fix:

 

 

References:
Redhat: Bug 1183461 – (CVE-2015-0235) CVE-2015-0235 glibc: __nss_hostname_digits_dots() heap-based buffer overflow 
 Security Advisory Critical: glibc security update

CentOS:     CentOS 7 – CVE-2015-0235

OracleLinux:   [El-errata] ELSA-2015-0092 Critical: Oracle Linux 6 glibc security update

Warning: The VM will try to fix the stack guard now.

Running Solaris Studio on EL7/ JDK8.

to fix the warning: