avahi-daemon[532]: SO_REUSEPORT failed: Protocol not available

scenario:

hit message error on os messages:

service avahi failed to start.

the problem is that SO_REUSEPORT is involved in linux kernel 3.9, while EK7 uses linux 3.10+.   but oracle uek kernel not yet.

w/r:

Reference:

Bug 484212 – net-dns/avahi-0.6.31-r2 with kernel <3.9 – avahi-daemon[3239]: SO_REUSEPORT failed: Protocol not available

Socket options SO_REUSEADDR and SO_REUSEPORT, how do they differ? Do they mean the same across all major operating systems?

WARNING : /lib64/libgudev-1.0.so.0: undefined symbol: g_type_class_adjust_private_offset

This is a scenario on xfce desktop crash after update some packages.

Error details:

 

Fix:

About libgudev, it’s a latest update on package: systemd/libgudev

 

check  oracle yum website:

glib2-2.36.3-5.el7.x86_64.rpm 14-May-2014 00:58 2.1 M
glib2-2.40.0-4.el7.x86_64.rpm 26-Dec-2014 03:17 2.2 M
glib2-2.42.2-5.el7.x86_64.rpm 21-Nov-2015 16:00 2.2 M

My glib2 package version is outdated .

Fix:
1. download the latest glib2-2.42.2
2. switch the terminal or recovery mode.
3. update glib2 package.
4. reboot to graphic mode.

firefox 39+ cannot access SSLv3 sites

Well, as described in
firefox_39_completely_breaks_older_sslv3_pages

I cannot access sslv3 sites on error: SSL_ERROR_UNSUPPORTED_VERSION

alternative… using Firefox38… …………

firefox-38.3.0-2.el7.centos.x86_64

set about:config to :

 

Could not open extension control file ‘pgcrypto.control’

Im now working on PostgreSQL on EL6

Im tring to create extension pgcrypto to store passwd.

failed. with following message

the fix is to reinstall postgresql94-contrib

Package postgresql94-contrib.x86_64 0:9.4.4-1PGDG.rhel6 will be installed

Fedora15 VIM安装Vundle和YouCompleteMe

这是一篇中文日志。

我要修改我的Fedora15节点上的vim配置,使用Vundle和YouCompleteMe.

下面是我在EL6/7上都使用的vimrc

https://github.com/asmca/zvimd/blob/master/new/vimrc
下载到~/.vimrc

然后, 安装Vundle

然后进入Vim界面, :VundleInstall

很重要的一点是Fc15已经很旧了,而且我又是一个重度RPM爱好者。 所以就有了下面的步骤

1) vim 版本过旧
当前版本是: vim-enhanced-7.3.315-1.fc15.x86_64
以下插件不兼容
UltiSnips requires Vim >= 7.4
YouCompleteMe unavailable: requires Vim 7.3.584+

索性选择较新的版本7.4.5
https://kojipkgs.fedoraproject.org//packages/vim/7.4.5/1.fc20/src/vim-7.4.5-1.fc20.src.rpm
然后

就正常升级了vim包, 而且近期的使用基本都没问题了。

2). YouCompleteMe可以直接安装即可, 但如果用–system-libclang 系统自带的clang版本就过旧了。

下载源包:
https://kojipkgs.fedoraproject.org//packages/llvm/3.4.2/3.el6/src/llvm-3.4.2-3.el6.src.rpm

需要修改一下spec包, 将lldb和gold去掉(因为这个rpm包里没有对应的源码)

然后rpm -bb llvm.spec

就能得到对应的rpm包

安装时候可能会遇到类似下面的错误

其实不用太关心, 我们只需要强制升级 clang 和llvm.x64相关的包。

然后对于相关的包,攺一下链接

升级完clang包,然后进入YouCompleteMe目录安装,

3). CMake版本问题
CMake Error at CMakeLists.txt:28 (cmake_minimum_required):
CMake 2.8.11 or higher is required.  You are running version 2.8.5
这个问题的话: 从这里下载RPM包
https://kojipkgs.fedoraproject.org//packages/cmake/2.8.12.2/2.fc21/src/cmake-2.8.12.2-2.fc21.src.rpm

因为我不用emacs,所以我修改了spec文件,将emacs相关的依赖删除了。
否则可以用
yum-builddep cmake-2.8.12.2-2.fc21.src.rpm来自己解决依赖

rpmbuild -bb cmake.spec 然后安装cmake包。

 
4) 至于boost, 如果使用到的话,我建议可以升级系统自带的boost包。版本过低。
https://kojipkgs.fedoraproject.org//packages/boost/1.57.0/8.fc23/src/boost-1.57.0-8.fc23.src.rpm

修改一下spec, 去除python3和mpich ,编译顺利

会发现旧的包有依赖

 

就强制升级

然后就可以用 下面语句编译 YouCompleteMe