copy pyenv installation onto other nodes

the step Im working on copying pyenv installation.

seems it’s simple, after setting env. it failed.

the problem is :


well after checking, it was the problem that ~/.pyenv/libexec was not in the $PATH.

comparing the src and dest env.:

the problem is that pyenv is now a binary, not instead.

1. using zip -y or –symlinks option on backup.
2. or after unzip, remove pyenv binary under ~/.pyenv/bin/, install sym-link.



Fedora 15


This time I notice this err. message on Idea log:


Well, it’s a classic issue on Acroread.

Notice here:
 Bug #986841  Debug log created by Adobe Reader browser plugin (

There’s no fix for even we do not have new Acroread version for linux.

But w/r provided in comment #21:

easy_install scapy failed

on EL 7, python 2.7.

Before installation

#easy_install scapy failed.

Error on :

root cause is:
On pypi page

latest pkg is
scapy-2.2.0-dev.linux-x86_64.tar.gz (md5)  //binary
Instead of
scapy-2.2.0-dev.tar.gz (md5)  //source


easy_install script will choose the binary pkg to download, which failed anyway.


w/r is to download source manually.

install python-rrdtool on EL7

Python 2.7.5
on EL 7



wk  is to inst basic package.

and then re-run easy_install

Anyway you can directly issue #yum install rrdtool-python.

Compile python3 on SLES 11 SP2

Install following RPMs before Steps:

Python3 source from: Python 3.3.5

Without zlib-devel,  You cannot enable zlib module built-in, install this RPM and re-compile python3 src.
about bzip2,  SLES doesnt provide extra bzip2-devel package, so just install bzip2 RPM is ok.

Without libopenssl-devel,  you cannot fetch https URL via easy_install,  it reports “unknown url type: https”


To Enablle ipython notebook:

Please install  sqlite-devel package: (UN OFFICIAL)
Im using:


1. install zeromq: # for pyzmq

Guide here:

2.  install dependencies:
easy_install  pyzmq jinja2 tornado
easy_install  sphinx readline
##### easy_install pysqlite # DO NO RUN THIS CMD. here hit bug, fixing… pysqlite doesn’t support python3 now, use internal sqlite3


3. run #ipython notebook ok.